lambda expressions are not supported at this language level

Lambda表达式是Java8的新功能,所以需要下载JDK8以及设置IDE里项目使用的jdk为jdk8和编译level也设置成1.8

Intellij IDEA选择菜单File–Project Structure–Project中,修改Project language level为8.0的那个选项.

project language level

project language level

友荐云推荐

关于开发者

开发者一枚...
此条目发表在IDE, Intellij IDEA, Java分类目录,贴了, , 标签。将固定链接加入收藏夹。

发表评论

电子邮件地址不会被公开。 必填项已用*标注